Warning about ATI Radeon Mobility X1400 on Linux

So here’s the issue, I bought the Inspiron E1705 with the upgraded video card option, which was the ATI Radeon Mobility X1400.  I also got the upgraded monitor, so the resolution on the monitor is 1920×1200.  Looks great in my opinion.  The issues are that there is currently no support at all for the video card in linux.  You can use the vesa drivers, which will give you a resolution of 1600×1200, which really does get annoying seeing things stretched.  The open source radeon drivers do not work with this chipset, and for some reason ATI has not released any linux drivers for this video card.

I’m going to keep a lookout for solutions on getting this video card working at the correct resolution in linux.  If you are a linux user, I would recommend that you try to get an nVidia card instead of an ATI if at all possible.  nVidia has already released linux video drivers for it’s newest mobility chipsets.  If I had that option when I got this laptop, I would definitely taken that option.

  1. Hello could you please give me a driver for ATI Radeon Mobility X1400. I use fedora core 5.
    thank you.

  2. It appears that an official Linux driver has been released. http://ati.amd.com/support/driver.html

  3. In case you are getting to this blog, ATI has now released drivers that can work with this card.

  4. Fedora Core 7 User

    In case you got this X1400 working on Fedora core 7
    leave a reply

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>