Category Archives: OS X

Ubuntu 10.10 Grub Update for OS X

This article builds upon Triple Booting Windows 7, OS X (Chameleon), and Ubuntu 9.10 (Grub2).

I recently updated my desktop to Ubuntu 10.10 and noticed that the grub commands have changed ever so slightly. With the new installation, I just needed to create the /boot/chameleon/ directory again and copy the boot0 from Chameleon 2.0-RC4 into the directory.

One thing that I noticed is that the new grub script also presents 32-bit and 64-bit options for my OS X installation now, which I’m up to 10.6.3. I take care of loading 64-bit through chameleon though. Here is my new entry for loading OS X through Cameleon.

 menuentry "Mac OS X Chameleon (on /dev/sda2)" {
     insmod hfsplus
     set root='(hd0,msdos2)'
     search --no-floppy --fs-uuid --set 62d3496cb25b59d8
     parttool (hd0,2) boot+
     chainloader (hd0,msdos4)/boot/chameleon/boot0
}

Sometimes it doesn’t copy correctly, but it should be two hyphens in front of no-floppy, fs-uuid, and set

You can find your uuid of your partitions by running blkid.

My current partition setup is:

  • /dev/sda1: Windows 7
  • /dev/sda2: OS X
  • /dev/sda3: Swap
  • /dev/sda4: Ubuntu Linux 10.10

OS X and Truemobile 1940 Issues Fixed

I currently picked up a $21 Dell Truemobile 1490 wireless card to put in my MSI Wind instead of the Realtek that’s in it. It install just fine, I got it working in Windows and Linux with no issues, but OS X was another story.

It wouldn’t connect to a wireless network at all by itself. On the menu bar it wouldn’t show any wireless networks. It did show “AirPort: Not configured”. If I opened the network preferences, it would show up as Ethernet 2 off. I would have to turn it back on each time I rebooted. I would then have to select the drop down box to pick a network because it still wouldn’t show any networks in the menu bar (and the menu bar would still say not configured). I could join my network and get an IP address, but the menu bar icon would not show any bars at all. It would be right next to the access point and I could surf the net just fine though.

Thanks to a post at InsanelyMac, I was able to finally fix this issue.

  1. Open Network Preferences
  2. Remove all devices except Firewire by highlighting the device and then clicking on the minus sign below the device list
  3. Reboot the machine
  4. Open Network Preferences
  5. Click the plus sign under the device list and select AirPort
  6. Click Apply

Since doing that, my menu bar works, networks are connected to automatically, even after reboots.

MSI Wind and Triple Booting

So I just purchased an MSI Wind from Microcenter and have already removed all the OS’ from it. I’m planning on installing Windows XP, Mac OS X, and Ubuntu Linux. Like most of my laptops, things are just plug and play to get it working, so I have a page to help me remember how I did it at: http://james.jamesandkristin.net/setting-up-msi-wind-to-triple-boot-windows-mac-os-x-linux

So far it looks like it’s perfect for what we need. A nice little laptop that will fit in Kristin’s purse and that will fit in little safes on vacation. Luckily my friend had a usb to ide adapter, so I didn’t have to purchase an external hard drive. I had looked into making a usb boot disks for all three os’s and even looked at using netboot to install. Netboot would have been cool, but I don’t have that much time to get it setup for all three OS’s.

One important note, you need to install Windows XP before anything else.